Opened 7 years ago

Closed 7 years ago

#199 closed defect (worksforme)

Ubuntu oneiric install fails

Reported by: https://me.yahoo.com/a/708OzwlrvP1JZDZoeOWD1hyBB5M-#39cde Owned by: Antoine Martin
Priority: critical Milestone:
Component: Website, Email, etc Keywords:
Cc:

Description (last modified by Antoine Martin)

Following the instructions on
http://winswitch.org/downloads/debian-repository.html?dist_select=oneiric

I get this error:

W: Failed to fetch http://winswitch.org/dists/dists/oneiric/main/binary-i386/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

I think 'dists' is appearing somewhere it shouldn't (see the dists/dists) above.

Change History (1)

comment:1 Changed 7 years ago by Antoine Martin

Component: AndroidWebsite, Email, etc
Description: modified (diff)
Priority: majorcritical
Resolution: worksforme
Status: newclosed

I've just tried here in a virtual machine and I cannot reproduce your problem.

There is no 'dists' in the repository path, the Release file is relative (still no 'dists' in it), and the packages referred to in the Packages file are relative to the repository path.

Here's an example: http://us.archive.ubuntu.com/ubuntu/dists/oneiric/main/binary-i386/ where the packages are in pool which is relative to the repository root http://us.archive.ubuntu.com/ubuntu/.

In any case, I've added a symlink from dists/dists to dists/. which should solve your problem, although it would be good to know the real cause of it...

Note: See TracTickets for help on using tickets.