Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#90 closed defect (wontfix)

100% cpu usage on some systems - twisted POLLIN

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: critical Milestone: 0.9.2
Component: Client Keywords:
Cc:

Description (last modified by Antoine Martin)

The pygtk bug is here
I had originally created a twisted bug here - but the problem is not in twisted.

And here is the Fedora bug: 660137

Gentoo bug: 353599

Ubuntu bug: 664920

Debian already has a patch for squeeze (against 2.17.0-4):
pygtk-wakeupfd-fix.patch

FreeBSD: bug 154755

So, I believe we should just leave it to the distributors to ship patched versions of the libraries we rely on rather than trying to workaround the issue (not even sure it is possible to do so)

However: if you want to use the fixed PyGTK RPMs/DEBs we have made using the above patch, please download them manually from:
http://winswitch.org/dists/

(as this is a system package - we will not push it to you automatically: this is your distribution's job)

Change History (18)

comment:1 Changed 7 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to Antoine Martin
Status: newaccepted

comment:2 Changed 7 years ago by Antoine Martin

Description: modified (diff)

comment:3 Changed 7 years ago by Antoine Martin

Description: modified (diff)
Resolution: wontfix
Status: acceptedclosed

comment:4 Changed 7 years ago by Antoine Martin

Description: modified (diff)

comment:5 Changed 6 years ago by Antoine Martin

Description: modified (diff)

comment:6 Changed 6 years ago by Antoine Martin

Description: modified (diff)

comment:7 Changed 6 years ago by Antoine Martin

Description: modified (diff)

comment:8 Changed 6 years ago by Antoine Martin

This seems to be fixed in r3423 following the discussion on bug 4658 at twistedmatrix.com - at last!

comment:9 Changed 6 years ago by Antoine Martin

Reverted in r3424 - this has too many side effects, the proper solution is for distributions to fix their version of PyGTK.
The PyGTK patch is available here

comment:10 Changed 6 years ago by Antoine Martin

Description: modified (diff)

comment:11 Changed 6 years ago by Antoine Martin

Description: modified (diff)

comment:12 Changed 6 years ago by Antoine Martin

Description: modified (diff)

comment:13 Changed 6 years ago by Antoine Martin

Fix has now been committed to pygtk trunk: commit 4cbd3c031289775f365c247f949d91facac4ba82

Still waiting for most distros to pick it up...

comment:14 Changed 6 years ago by Antoine Martin

Posted a status update

There are pygtk RPMs and DEBs fixing the bug here:
http://winswitch.org/dists/

comment:15 Changed 6 years ago by Antoine Martin

Description: modified (diff)

comment:16 Changed 6 years ago by Antoine Martin

Description: modified (diff)

comment:17 Changed 6 years ago by Antoine Martin

Description: modified (diff)

comment:18 Changed 6 years ago by Antoine Martin

Fedora 14 has now received the update... And Fedora 15 has been released with the patch already included.

Ubuntu natty has received the update, maverick is "committed" (not sure it has been pushed out yet)
Which only leaves Ubuntu Lucid unpatched AFAIK.

Note: See TracTickets for help on using tickets.