Opened 10 years ago

Closed 9 years ago

#105 closed defect (fixed)

RDP support

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 0.10
Component: Client Keywords:
Cc:

Description (last modified by Antoine Martin)

Following popular demand... Let's implement RDP client/server support.

  • an rdesktop client wrapper
  • an xrdp based server plugin (which will need to override the authentication phase with one of our tokens - replace sesman?)
  • the full server build for Windows

The Windows server is going to need:

  • way to control the RDP server if possible (unlikely)

Depends on #104

Change History (5)

comment:1 Changed 10 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to Antoine Martin
Status: newaccepted

comment:2 Changed 10 years ago by Antoine Martin

Milestone: 0.101.0

comment:3 Changed 9 years ago by Antoine Martin

initial RDP support: r2588

Limitations (mostly of RDP itself):

  • current user is logged out if we take over the session!
  • seamless is very unreliable and requires the changes to the registry to prevent Windows from displaying the whole desktop... sigh (set NoDesktop==0)
  • VNC seems to crash if launched from an RDP session!

Still a fair amount of work to do on this...

Last edited 8 years ago by Antoine Martin (previous) (diff)

comment:4 Changed 9 years ago by Antoine Martin

Milestone: 1.00.10

comment:5 Changed 9 years ago by Antoine Martin

Resolution: fixed
Status: acceptedclosed

Not doing seamless mode as it is just completely unusable for our purpose.

RDP support is now pretty good: the active windows display session is detected and can be sent around, we detect session events so we know when it is re-connected to the main display (when the user logs in again).

VNC sessions will drop when RDP is started (not a bug - a feature: VNC can't run when RDP is active), and the UI should prevent users from trying to start a VNC copy when RDP is active.

Note: See TracTickets for help on using tickets.