Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#151 closed defect (worksforme)

Can't connect to servers with special characters in the SSH password.

Reported by: boltronics Owned by: Antoine Martin
Priority: major Milestone: 0.12
Component: Client Keywords: 0.12.3 ssh password
Cc: [email protected]

Description (last modified by Antoine Martin)

Server: WinSwitch 0.12.3, Ubuntu 10.04 (using the WinSwitch repo)
Client: WinSwitch 0.12.3, Debian Wheezy (using the WinSwitch Sid repo)

"Match Username" was ticked, I customized the "Sound Monitor Device", and set the Menu Size to "Small" on the client (since the menus were huge on Debian by default - a different bug I suspect). Default Desktop Screen Size was set. Everything else was using the defaults (xpra for Seamless, vnc for Desktop).

I used a password on the server which contained (amongst other characters) the characters ")$;". Presumably one of these prevented the SSH connection from connecting, since the password prompt kept re-appearing. I changed the password on the Ubuntu server to only use an alphanumeric password, and then the password was accepted.

Change History (10)

comment:1 Changed 8 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to Antoine Martin
Status: newaccepted

Thanks for the details, I will try to reproduce here.

comment:2 Changed 8 years ago by Antoine Martin

Resolution: worksforme
Status: acceptedclosed

Sorry, I cannot reproduce the problem. I've tried all sorts of weird characters and cannot get it to refuse login (unless I type it wrong).

It seems quite odd too since none of the password strings are interpreted anywhere in the code, so in theory no characters can cause the sort of problem you describe.

Is it possible that you typed the password from a console with a different keyboard mapping? This would cause the special characters to be different from what you expect (what you press on the keyboard in front of you) and would cause the symptoms you describe.

Closing.

comment:3 Changed 8 years ago by boltronics

Well... I tried. You really tested between Wheezy and Natty?

Both keyboards use a standard US keyboard - so no the keyboard mappings are the same. I use synergy between machines - and I've never seen any key mapping problem with it - and I use it all the time every weekday. I even tried typing the password in the clear in gedit just to make sure something like this wasn't happening, and it was fine.

Both machines have different passwords, and when I tried making the other the server (which doesn't have symbols in its password) it worked straight away so I figured it was a password issue.

Then I changed the password (after about 20 password attempts, after logging out and in again, changing all kinds of settings, deleting my client ~/.winswitch directory and starting again etc etc.) and focused on looking at what was different between the two - and passwords was the obvious major one. I tried to have a look at what was saved in the config file, but noticed it was encrypted so didn't dig much deeper. It worked first time after changing it, so that's some pretty major coincidence if it's something else. I wouldn't have wasted my time with a report if I wasn't sure there was an issue.

Maybe the order is important. I wasn't going to provide this as I thought I might have been using it for something else, but it turns out I'm not. It's "$k4D5f;)" (without quotes). Please try that.

If you still have no luck I suppose the problem could be specific to my distro/setup somehow, in which case I'll do more testing when I'm at work tomorrow (the other machine is my work machine). Since one is Ubuntu and one is Debian, maybe the different libraries conflict somehow. There were plenty of other obvious bugs on one and not the other, so this seems a plausible possibility.

In the meantime, please reopen this.

comment:4 Changed 8 years ago by Antoine Martin

Resolution: worksforme
Status: closedreopened

Will have to install wheezy to test with the exact same distro versions...

comment:5 Changed 8 years ago by boltronics

Fair enough. Okay, I've done more testing. I changed the password back, and it failed to connect with that password. I then tried setting it to something similar (same special characters in the same location), and then it started working with that.

Surprised, I set it back to what it was before that, and it's working now.

I then closed down both server/client, deleted all the .winswitch directories and started again from scratch... and so far I have not been able to reproduce the problem again for the life of me. It's driving me nuts!

I can see why you marked it "works for me". I hate to say it, but you might as well close this. If it comes back, or somebody else catches the same problem, I guess it can be re-opened. Sorry for potentially wasting your time.

comment:6 Changed 8 years ago by Antoine Martin

Resolution: worksforme
Status: reopenedclosed

No probs, feel free to re-open if this can be re-produced.

comment:7 Changed 8 years ago by Antoine Martin

Regarding the "since the menus were huge on Debian by default - a different bug I suspect", would you mind grepping for "default_size" in your applet.log?

The default is 16, unless the size of the tray icon can be detected, in which case it uses that.

comment:8 Changed 8 years ago by boltronics

Yikes - the log is 338M. I had no idea it would get so big! I'm on a smallish SSD and actually ran out of space today.

Anyway, all lines are all like this (with only the timestamp differing):
[II] 2011/27/06 11:26:03 WinSwitchApplet?.ready() set icon default_size=48 from size=200

Happy to help out where I can.

comment:9 Changed 8 years ago by Antoine Martin

Yikes indeed! Have you got debug mode on by any chance? The log is not meant to grow unless something happens, and the timer jobs (ie: screenshots every 30s) should be logging as 'debug' only..

Thanks for the grep, it looks like the panel size is detected wrong, 200 seems a tad big for a panel height!? Is this using unity or gnome-shell or KDE?

Thx!

comment:10 Changed 8 years ago by boltronics

Doh! Yes, I had verbose/debug mode switched on and forgot about it - thanks for the hint. Guess that'll do it. :)

I'm just using the stock Debian Wheezy Metacity (2.30.1-3) and GNOME Desktop (2.30.2-4) packages. I have lots of KDE-related libraries installed (but not the actual K Desktop Environment), and I believe TWM is the only other window manager I have installed (but never even ran it). I don't believe Unity or GNOME Shell are in the Debian repos yet, and the winswitch/sid repo is the only 3rd-party repo I've configured in apt on this box.

Note: See TracTickets for help on using tickets.