Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#172 closed enhancement (fixed)

ability to upgrade xpra server sessions in place

Reported by: pmarek Owned by: Antoine Martin
Priority: minor Milestone: 0.12
Component: Server Keywords:
Cc:

Description (last modified by Antoine Martin)

At the moment, if one uses "xpra upgrade" on an existing xpra session, winswitch will see that the server process it had started has now terminated and it will close the session and kill all the remaining session processes.

Options:

  • detect an exit code from the xpra server which will mean "upgrade me" and re-spawn it.

This could be tricky as there are daemons involved, pipes and file descriptors, gio file watchers, etc.

  • change the xpra code to exec the new process in place so we keep the same pid and this becomes transparent to winswitch

Another benefit is that all the start options would then be preserved too (password, etc) - and we could even envisage that extra options could be specified to override existing ones

Attachments (1)

server.logfile (5.3 KB) - added by pmarek 7 years ago.
winswitch server logfile

Download all attachments as: .zip

Change History (7)

comment:1 Changed 8 years ago by Antoine Martin

Milestone: 1.1
Owner: changed from Antoine Martin to Antoine Martin
Status: newaccepted

edit: the original bug made it sound like the problem was with upgrades to winswitch, but in fact the problem is with xpra sessions exiting on upgrade.

Restarting the winswitch server should not lose any sessions and if your client is set to auto-resume, it should re-connect the sessions too in the event that some of them drop (which they should not do - as each session uses its own daemon)

Last edited 8 years ago by Antoine Martin (previous) (diff)

comment:2 Changed 8 years ago by Antoine Martin

Resolution: worksforme
Status: acceptedclosed

comment:3 Changed 8 years ago by Antoine Martin

Description: modified (diff)
Milestone: 1.10.12
Resolution: worksforme
Status: closedreopened
Summary: "winswitch upgrade"ability to upgrade xpra server sessions in place

comment:4 Changed 8 years ago by Antoine Martin

Description: modified (diff)

comment:5 Changed 7 years ago by Antoine Martin

Resolution: fixed
Status: reopenedclosed

done in r4764

comment:6 Changed 7 years ago by pmarek

Yesterday I got my xpra killed on upgrade.

Here's part of the winswitch server logfile, perhaps there's something in it.

Changed 7 years ago by pmarek

Attachment: server.logfile added

winswitch server logfile

Note: See TracTickets for help on using tickets.