Opened 8 years ago

Closed 7 years ago

#189 closed defect (worksforme)

Error on xpra-reconnect

Reported by: pmarek Owned by: Antoine Martin
Priority: major Milestone:
Component: Server Keywords:
Cc:

Description

I had an xterm, a "git gui" and a gvim connected via winswitch from a remote machine.
After going away and coming back, only one of the sessions (xterm) could be resumed; new sessions (xterm again) could be started.

Here's a filtered strace on winswitch_server when trying a reconnect:

write(2, "/usr/lib/pymodules/python2.6/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display\n  warnings.warn(str(e), _gtk.Warning)\n", 130) = 130
write(2, "/usr/lib/xpra/xpra/xposix/gui.py:15: GtkWarning: IA__gdk_display_get_name: assertion `GDK_IS_DISPLAY (display)' failed\n  _display = gtk.gdk.get_display()\n", 154) = 154
write(2, "Traceback (most recent call last):\n", 35) = 35
write(2, "  File \"/usr/bin/xpra\", line 7, in <module>\n", 44) = 44
write(2, "    ", 4) = 4
write(2, "xpra.scripts.main.main(__file__, sys.argv)\n", 43) = 43
write(2, "  File \"/usr/lib/xpra/xpra/scripts/main.py\", line 232, in main\n", 63) = 63
write(2, "    ", 4) = 4
write(2, "run_client(parser, options, args, mode)\n", 40) = 40
write(2, "  File \"/usr/lib/xpra/xpra/scripts/main.py\", line 367, in run_client\n", 69) = 69
write(2, "    ", 4) = 4
write(2, "from xpra.client import XpraClient\n", 35) = 35
write(2, "  File \"/usr/lib/xpra/xpra/client.py\", line 25, in <module>\n", 60) = 60
write(2, "    ", 4) = 4
write(2, "from xpra.platform.gui import ClientExtras\n", 43) = 43
write(2, "  File \"/usr/lib/xpra/xpra/platform/gui.py\", line 16, in <module>\n", 66) = 66
write(2, "    ", 4) = 4
write(2, "from xpra.xposix.gui import *\n", 30) = 30
write(2, "  File \"/usr/lib/xpra/xpra/xposix/gui.py\", line 16, in <module>\n", 64) = 64
write(2, "    ", 4) = 4
write(2, "assert _display, \"cannot open the display with GTK, is DISPLAY set?\"\n", 69) = 69
write(2, "AssertionError", 14) = 14
write(2, ": ", 2) = 2
write(2, "cannot open the display with GTK, is DISPLAY set?", 49) = 49
write(2, "\n", 1) = 1

Change History (4)

comment:1 Changed 8 years ago by pmarek

Killing the winswitch_server and connecting again from the client solves that problem.

comment:2 Changed 8 years ago by pmarek

No, the xpra session dies shortly after that.

Upgrading winswitch to 0.11.10 doesn't help ... the sessions are flaky.

I can eg. connect to the gvim session, and have it for a few seconds ... but then it vanishes again.

client log says

[EE] 2012/17/02 10:35:01 ProtocolHandler.check_response_received(('ping', 89)) no response received - terminating connection with <bound method ExecLineChannel.stop of <winswitch.net.
[II] 2012/17/02 10:35:01 ExecLineChannel.stop(False,Timeout: no response received after 10 seconds) stopped=True
[EE] 2012/17/02 10:35:01 ProtocolHandler.check_ping_echo_received(8) server=ServerConfig(hostname:186916980035983), pingechocount=6

comment:3 Changed 7 years ago by Antoine Martin

Owner: changed from Antoine Martin to Antoine Martin
Status: newaccepted

Being able to open the display is essential.

Are you certain that DISPLAY is set correctly when launching the client - it must be or you would not be able to interact with the winswitch applet. Just checking.

I am a bit puzzled though because you claim the strace is from winswitch_server, but the server never launches the client!? (well, to be pedantic, it does occasionally start a client, but not a XpraClient which requires a DISPLAY)

comment:4 Changed 7 years ago by pmarek

Resolution: worksforme
Status: acceptedclosed

Well, TBH, I'm not sure anymore.

If I can reproduce that with the current packages I'll reopen this ticket with more details.

Note: See TracTickets for help on using tickets.