Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#207 closed defect (fixed)

path munge in OSX Helpers scripts

Reported by: tlc Owned by: Antoine Martin
Priority: minor Milestone:
Component: OSX Build Keywords:
Cc:

Description

I install the OSX winswitch package and run xpra from it. I run the script that sets up the dynamic libs, etc. here:

/Applications/Window-Switch.app/Contents/Helpers/xpra

This script has the odd behavior of not working unless you run it from a parent dir of the script. Otherwise you get

$ /Applications/Window-Switch.app/Contents/Helpers/xpra
/Applications/Window-Switch.app/Contents/Helpers/xpra: line 77: /Users/troy//Applications/Window-Switch.app/Contents/Resources/bin/xpra: No such file or directory
/Applications/Window-Switch.app/Contents/Helpers/xpra: line 77: exec: /Users/troy//Applications/Window-Switch.app/Contents/Resources/bin/xpra: cannot execute: No such file or directory



I think the issue is at the top of the file

if [[ "$0" == `pwd`* ]] || [[ "$0" == "//"* ]]; then
    full_path="$0"
else
    full_path="`pwd`/$0"
fi

Attachments (1)

osx-xpra-launcher.png (205.5 KB) - added by Antoine Martin 7 years ago.
new version now has an xpra sub application - with the launcher

Download all attachments as: .zip

Change History (3)

comment:1 Changed 7 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

I didn't write this code, so I made the (ugly/hacking) minimal change I could think of, see r4941

This will be part of the 0.12.15 release - due shortly.

Changed 7 years ago by Antoine Martin

Attachment: osx-xpra-launcher.png added

new version now has an xpra sub application - with the launcher

comment:2 Changed 7 years ago by Antoine Martin

trunk now includes and Xpra "app" hidden inside the winswitch app - see screenshot above.

Note: See TracTickets for help on using tickets.