Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#211 closed defect (invalid)

SSH connection failure

Reported by: onlyjob Owned by: Antoine Martin
Priority: major Milestone:
Component: UI Keywords:
Cc:

Description

On Debian establishing SSH connection from Winswitch fails with the following error:

EE] 2012/10/08 02:13:11 format_util.logerr(SSH-2.0-OpenSSH_6.0p1 Debian-2)arguments are missing quotes
[EE] 2012/10/08 02:13:11 ProtocolHandler.handle_command(SSH-2.0-OpenSSH_6.0p1 Debian-2) command parsing failed
[EE] 2012/10/08 02:13:11 format_util.logerr(Protocol mismatch.)arguments are missing quotes:Protocol mismatch.
[EE] 2012/10/08 02:13:11 ProtocolHandler.handle_command(Protocol mismatch.) command parsing failed
[EE] 2012/10/08 02:13:11 ServerReceiver.connectionLost([Failure instance: Traceback (failure with no frames): <class 'twisted.internet.error.ConnectionLost'>: Connection to the other side was lost in a non-clean fashion.\n])
[EE] 2012/10/08 02:13:11 ServerReceiverConnectionFactory.clientConnectionLost(<twisted.internet.tcp.Connector instance at 0x4990f38>,[Failure instance: Traceback (failure with no frames): <class 'twisted.internet.error.ConnectionLost'>: Connection to the other side was lost in a non-clean fashion.\n])

Attachments (1)

squeeze-connect-ok.png (175.1 KB) - added by Antoine Martin 7 years ago.
example of a connection settings pane with ssh tunnelling enabled

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by Antoine Martin

Owner: changed from Antoine Martin to Antoine Martin
Status: newaccepted

Hmm, I've never seen this.

It looks like the ssh version string is interpreted as a command sent by the remote endpoint. I will have to test this against the same version of debian/ssh to figure out what is happening here.

Are you using keys or ssh password? Anything else I need to know to reproduce? (client's ssh version?)

comment:2 Changed 7 years ago by onlyjob

Thanks, this is only happening with password authentication.

ssh client version is 'OpenSSH_6.0p1 Debian-2, OpenSSL 1.0.1c 10 May 2012'
(package 'openssh-client' 1:6.0p1-2)

comment:3 Changed 7 years ago by Antoine Martin

Which version of debian do I need for testing? wheezy on both client and server?

comment:4 Changed 7 years ago by onlyjob

Yes please.

comment:5 Changed 7 years ago by Antoine Martin

Resolution: invalid
Status: acceptedclosed

Just tested and it worked just fine, I used a single VM and connected via ssh to 127.0.0.1.

I think maybe you've set port 22 but you have also unticked "ssh tunnel" - see screenshot. Feel free to re-open if not.

Changed 7 years ago by Antoine Martin

Attachment: squeeze-connect-ok.png added

example of a connection settings pane with ssh tunnelling enabled

comment:6 Changed 7 years ago by onlyjob

Quite possible that I did exactly that - many thanks for your explanation. I'll try again with remote machine and report.

Note: See TracTickets for help on using tickets.