Opened 7 years ago

Closed 7 years ago

#216 closed defect (fixed)

wheezy package issues

Reported by: remche Owned by: Antoine Martin
Priority: major Milestone:
Component: UI Keywords: Applet
Cc:

Description

hi,
I tried winswitch on a wheezy install, I had to :

  • install manually python-appindicatore
  • changing tray_icon_name for winswitch_indicator, as winswitch_applet file does not exist, and is not in ALL_BUILTIN (ui/icons.py).

Thx for your work,
cheers,
rémi

Change History (5)

comment:1 Changed 7 years ago by remche

Hum. In fact, applet was running, but nothing working after that.
I had to copy winswitch_indicator to winswitch_applet, and add winswitch_applet to ALL_BUILTIN...

comment:2 Changed 7 years ago by Antoine Martin

Owner: changed from Antoine Martin to Antoine Martin
Status: newaccepted
  • the tray system that you use is up to you, either appindicator or the regular StatusIcon based system tray. This really depends on your desktop environment. I am afraid that we can't add this as a dependency to the package, not even a "recommends" one because this API does not degrade well (last time I tried 'appindicator' would fails silently)

  • Can you expand on what you did with tray_icon_name? Which files did you change and why? (ideally a patch) The change you suggest may well break other things as this appindicator API is a bit of a nightmare to deal with (older versions cannot load with a full path, etc)

FYI: "winswitch_applet.png" should exist in /usr/share/icons/hicolor/*/apps/ because this is the only place where some versions of appindicator can load it from..


Edit: please specify your setup/desktop environment so I can try to reproduce.

Last edited 7 years ago by Antoine Martin (previous) (diff)

comment:3 Changed 7 years ago by Antoine Martin

Based on what you said, there is an untested fix in r4990, and beta packages with the fix included here: http://winswitch.org/beta/wheezy/main/

Let me know if that solves your problem.

Last edited 7 years ago by Antoine Martin (previous) (diff)

comment:4 Changed 7 years ago by remche

It does !
Thx again for your great work.
Cheers,
rémi

comment:5 Changed 7 years ago by Antoine Martin

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.