Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#224 closed enhancement (notabug)

Winswitch on Win 7

Reported by: Demontager Owned by: Antoine Martin
Priority: major Milestone:
Component: Global Keywords: windows7, linux
Cc:

Description

I need to use Win7 Ultimate machine as server for applications and Lubuntu 12.10 as client. The problem is i don't see any applications available to launch in tray icon menu - not in Windows 7 neither Lubuntu.
Sure i connected to server and vice-versa. I tried to match same protocol - nx on Win7 and Linux, but no result.
When checking connection configuration i see this -

Seamless Default "None available! Microsoft Microsoft Windows limitations"

Desktop Default "None available! Microsoft Microsoft Windows limitations"
So i assume the problem in Win 7 Ultimate support. I used before to connect to Windows 2003 Server from Gentoo and it just worked fine.

Attachments (1)

lubuntu.png (49.0 KB) - added by Demontager 7 years ago.
Lubuntu connection status

Download all attachments as: .zip

Change History (19)

Changed 7 years ago by Demontager

Attachment: lubuntu.png added

Lubuntu connection status

comment:1 Changed 7 years ago by Antoine Martin

Resolution: notabug
Status: newclosed

Did you try clicking on the big button next to that message?

You would have found this message on the protocol page:



About the Microsoft Windows Limitation message: you may see this warning when connected to a Windows server.
This is to indicate that Windows servers can only export their local display (and even this is subject to limitations imposed by Microsoft, see RDP protocol for details),
you will not be able to start new applications or virtual desktop sessions.

This limitation is imposed by the fact that Microsoft Windows is unable to support any of the protocols above in any useful way (as a server only).

This does not prevent you from starting and connecting to sessions on any other type of supported servers as the client for Windows supports all protocols.


In theory, you could try exporting single applications via seamless RDP - but this never works reliably, so it is not supported by winswitch.

comment:2 Changed 7 years ago by Demontager

Yes, i saw this explanations about Windows limitations.
That means I can't export any Win7 applications to Linux desktop, right ? And how about Linux, why it not possible to export its application to Windows ?
According to slideshow on winswitch main page, initially some application started on Linux then its window transferred to MAC, then to Windows.

And moreover - this video confusing me https://winswitch.org/video/

It represents what actually i need to do - export to Linux applications installed on Windows. So Windows 7 not supported, is it ? On video used Windows XP, assume I may get what i need on XP ?

Last edited 7 years ago by Demontager (previous) (diff)

comment:3 Changed 7 years ago by Antoine Martin

Exporting from Linux works very well, and works with any version of Windows (as client), Windows 7 and 8 included.

You're not showing/telling me what your setup looks like so I have no idea why you cannot start applications on the Linux server.

comment:4 Changed 7 years ago by Demontager

Tried to do my best to show all settings. http://nixtalks.com/winswitch.ogv

Host system - Linux Lubuntu amd64
VirtualBox? Guest - Windows 7 Ultimate amd64

comment:5 Changed 7 years ago by Antoine Martin

You need to start sessions on the Linux box - on the video you used the start dialog on the win32 server.
Please specify your distro/version.
It looks like it didn't detect /var/log/wtmp properly as it isn't giving you the option of shadowing your X11 display.

If you select 'Start Application' from the main popup menu, then select your Linux server as "server", what do you see?

comment:6 Changed 7 years ago by Demontager

It shows Ubuntu, but I got Lubuntu 12.10 http://lubuntu.net/

uname -a
Linux cat-U36SD 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

​Tried applications' sessions - http://nixtalks.com/winswitch2.ogv

Last edited 7 years ago by Antoine Martin (previous) (diff)

comment:7 Changed 7 years ago by Antoine Martin

When you are on the start session dialog, choose a different server. As I said before, your windows server cannot export commands, so choose the one that can. I am a bit puzzled as to why your applet dialog does not show you the option to start commands on the Linux server... that's odd. The applet normally starts an embedded server for you and connects to it. Did you make any changes to the configuration?
Are you sure you have the server running on Linux?

/usr/libexec/winswitch/server_portinfo

Should show you the details (port number and ID)


If that is the case, then you should familiarize yourself with the applet first, without even using a windows PC connected to it, then once you have a session started there you can connect with your windows PC and move the session there.

If you have the winswitch server running on your Linux PC already, starting a new session is as simple as typing this (saves fiddling with the start dialog):

wcw xterm

comment:8 Changed 7 years ago by Demontager

Sorry for late reply, i been out of internet for few days, but i played around with winswitch all these days. But no luck, i think my problem in virtualization , as i'm using VB to run all my machines.
I even checked winswitch between 2 Windows VMs - XP and Win7 and i was able to connect only but not use their apps via winswitch. When i try to run application session on any VM i get - "no compatible protocols found for starting a command on $hostname" warning.

What i want to do is find another physical PC install winswitch on it and test again.

p.s. to connect between VMs i use Android phone as router and bridge mode.

Last edited 7 years ago by Demontager (previous) (diff)

comment:9 Changed 7 years ago by Antoine Martin

You have not yet proven that this has anything to do with the network.
Your first step absolutely *must* be to start a session on one of the linux boxes you want to use as session server, suspend it and resume it there to test.
If that works and you cannot connect to that same session from the Windows box then you can blame the network setup.
I've pasted a number of commands you can simply cut and paste, but if you chose to do something else instead... then you're on your own.

You have checked the FAQ entry on virtualization right? (use bridged mode for networking so hosts can see each other on the lan)
If your network topology is unusual, I would use ssh mode because all the session connections will then re-use the same ssh tunnel you create to connect to the server.

comment:10 Changed 7 years ago by Demontager

Sure i read all available FAQ, that's why i mentioned how my VMs connected, as FAQ say bridged connection should be fine.
As to the commands - Lubuntu has bit deferent paths. I got no /usr/libexec

U36SD:~$ /usr/lib/winswitch/server_portinfo
[II] 2012/14/11 15:40:57.461067 globals os.uname=('Linux', 'cat-U36SD', '3.5.0-17-generic', '#28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012', 'x86_64')
[II] 2012/14/11 15:40:57.477862 globals python package info: __version__=0.12.17
[II] 2012/14/11 15:40:57.479042 globals version=0.12.17 (svn revision 5071 - 0 local modifications), built on winswitch.org by buildbot, 2012-10-08, release_build=True
[II] 2012/14/11 15:40:57.479231 globals uid=1000, username=cat, name=cat, hostname=cat-U36SD, locale=en_US, argv=[/usr/lib/winswitch/server_portinfo]
[II] 2012/14/11 15:40:57.479364 globals Python version 2.7.3 (default, Sep 26 2012, 21:51:14) [GCC 4.7.2]

As to the xterm - it starts new terminal window, but parent shows:

~$ wcw xterm
/usr/bin/wcw: failed to send via socket

Yes, VMs, found each other with ZeroConf? and applied connection settings in auto.

Last edited 7 years ago by Demontager (previous) (diff)

comment:11 Changed 7 years ago by Antoine Martin

That tells me that you do not have a winswitch server running on the system where you ran those commands (at least not as that user)... so you will not get anywhere until you have a winswitch server running on that box!

comment:12 Changed 7 years ago by Demontager

I assumed that as well that means default winswitch install with Lubuntu 12.10 just not works out from box. I used Quantal Quetzal (12.10) beta package to install so it done autoinstall with apt. Something missing on my system, is any debug info can i retrieve from winswitch ?

comment:13 Changed 7 years ago by Antoine Martin

Did you start the server? How?
Did you get an error then?
All that is well documented too.. ..gotta go.

comment:14 Changed 7 years ago by Demontager

Just launched winswitch app as appeared on my video. What else should be ?
Then i connected via ssh to own localhost, but here it was connected for 10 secs and disconnected. No any error at least in GUI.

comment:15 Changed 7 years ago by Antoine Martin

You should not connect to localhost via ssh, the server runs embedded in the applet already. There is no need to do anything to connect to the embedded server. And if you go to the configuration page for the embedded server, all the options will be greyed out.


I've done this hundreds, if not thousands of times by now, during testing: install winswitch, click start menu icon, tray appears start application from there. Sounds to me like you are overcomplicating things.

comment:16 Changed 7 years ago by Antoine Martin

see #223 and #225

Last edited 7 years ago by Antoine Martin (previous) (diff)

comment:17 Changed 7 years ago by Demontager

antonie, got winswitch working now.
Remember when you gave me a link to #225 ?
Than i checked my log and found similar error

[EE] 2012/17/11 14:14:28.608243 WinSwitchServer.ready()
[ee] 2012/17/11 14:14:28.610882 Traceback (most recent call last):
[ee] 2012/17/11 14:14:28.610947   File "/usr/lib/python2.7/dist-packages/winswitch/server/controller.py", line 316, in ready
[ee] 2012/17/11 14:14:28.610986     self.assign_virt_utils()
[ee] 2012/17/11 14:14:28.611022   File "/usr/lib/python2.7/dist-packages/winswitch/server/controller.py", line 405, in assign_virt_utils
[ee] 2012/17/11 14:14:28.611056     from winswitch.virt.vnc_server_util import VNCServerUtil
[ee] 2012/17/11 14:14:28.611089   File "/usr/lib/python2.7/dist-packages/winswitch/virt/vnc_server_util.py", line 16, in <module>
[ee] 2012/17/11 14:14:28.611145     from winswitch.virt.server_util_base import ServerUtilBase
[ee] 2012/17/11 14:14:28.611182   File "/usr/lib/python2.7/dist-packages/winswitch/virt/server_util_base.py", line 40, in <module>
[ee] 2012/17/11 14:14:28.611215     from winswitch.util.xkbmap_util import set_keymap
[ee] 2012/17/11 14:14:28.611248   File "/usr/lib/python2.7/dist-packages/winswitch/util/xkbmap_util.py", line 173
[ee] 2012/17/11 14:14:28.611282 SyntaxError: Non-ASCII character '\xc3' in file /usr/lib/python2.7/dist-packages/winswitch/util/xkbmap_util.py on line 173, but no encoding declared; see http://www.python.org/peps/pep-0263.html for details

Error is dummy simple - "Non-ASCII character" line 173 showing charmap for Norwegian language and there one letter " å " stopping a script execution.

173 line in full:

1044: ("NOR", "Norway (Bokmål)","Norwegian",                1252,   "no", ["nodeadkeys", "dvorak", "smi", "smi_nodeadkeys", "mac", "mac_nodeadkeys"]),

When i removed " å " then winswitch started normally, and i was able to get applications' sessions which were not working before. Tested seamless connections from WinXP and Win7 works fine.
antonie, actually initially i was looking a way to start Windows OS applications in seamless mode on Linux, but winswitch as i clearly understood not supporting (right?) that because of Windows OS limitations ?

Last edited 7 years ago by Antoine Martin (previous) (diff)

comment:18 Changed 7 years ago by Antoine Martin

As per #223 there are at least 4 options to get rid of this bug - have you tried any of them? They're all cleaner than deleting this line...

As for starting Windows applications via winswitch, this would be do-able in theory using RDP, but in practice it is just too hard to get right. See Seamless RDP for details (good luck, you will need it)

Note: See TracTickets for help on using tickets.