Opened 6 years ago

Closed 6 years ago

#231 closed defect (invalid)

Debian: xpra v0.8.1 attempts to start Xvfb despite not depending on it

Reported by: Optionator Owned by:
Priority: major Milestone:
Component: Xpra Keywords:
Cc:

Description

I am using your deb repository on a Debian 6.0.6 system and just upgraded xpra to v0.8.1. Xvfb got removed, because it was not depended on anymore. xserver-xorg-input-void and xserver-xorg-video-dummy were installed to fulfill dependencies.

Attempting to start xpra:

$ xpra start :999
cannot load vpx codec: /usr/lib/python2.6/dist-packages/xpra/vpx/codec.so: undefined symbol: vpx_codec_enc_config_default
No handlers could be found for logger "xpra.sound.gstreamer_util"
Entering daemon mode; any further errors will be reported to:
  /home/user/.xpra/Squeezy-999.log
$ cat ~/.xpra/Squeezy-999.log
Error starting Xvfb: [Errno 2] No such file or directory
2013-02-05 14:00:13,957 removing socket /home/user/.xpra/Squeezy-999

I installed xvfb manually and now xpra works like it did before, but since the depencies changed, I believe, that´s not the intended behaviour.

Change History (1)

comment:1 Changed 6 years ago by Antoine Martin

Resolution: invalid
Status: newclosed

I've moved your ticket to xpra's tracker: https://www.xpra.org/trac/ticket/248


FYI:

  • I will also try to fix the vpx codec warning
  • the logger warning is already fixed in trunk
Note: See TracTickets for help on using tickets.