Opened 9 years ago

Closed 9 years ago

#277 closed defect (fixed)

WinSwitch Wont Start OSX 10.9.5

Reported by: student_meh Owned by: student_meh
Priority: blocker Milestone: 0.12
Component: Global Keywords: start osx 10.9.5


WinSwitch? does not seem to start at all in OSX 10.9.5

I have tried to look for a verbose mode to start WinSwitch? from terminal to see what is up but I was not able to find any flaggs that the app allows.

I have went through security and firewall check but no luck. The app simply does not start at all.

Can you please enable verbose flag. Previous version of WinSwitch? worked fine.

Thank you very much.

Change History (9)

comment:1 Changed 9 years ago by Mc128k

Hi, I am having the same issue. If you start the app from terminal you can see some logs. Apparently some icon resouces are missing, see here my log:

[II] 2015/27/07 16:57:08.698837 net_util.<module>() netifaces loaded sucessfully
[II] 2015/27/07 16:57:08.699161 net_util.<module>() successfully loaded C library from /usr/lib/libc.dylib
[DD] 2015/27/07 16:57:08.706595 icon_cache.<module>() pixmaps_dir=['/Applications/', 
[EE] 2015/27/07 16:57:08.708622 icons.init_icons() missing winswitch.png
Last edited 9 years ago by Antoine gmail (previous) (diff)

comment:2 Changed 9 years ago by Antoine gmail

The missing icon should not be fatal, though obviously if it's missing the icon used for the tray... the tray may be invisible or use the default application icon (which should be the same).

You can get more debug logging by starting the applet with --debug-mode.

comment:3 Changed 9 years ago by Mc128k

The app crashes (the console proves it, no process is left) and it appears that all resources are missing in the share/winswitch/* folders. Copying the icon file here produces another error message:

[EE] 2015/27/07 17:05:36.373254 icons.init_icons() missing winswitch_logo.png

And this file does not exist. I am sure this problem happeded some time ago too, I have been able to "run" it by placing images in these folders. Is there something wrong in the compilation scripts? Maybe a bunch of stuff is not being copied.

Last edited 9 years ago by Antoine gmail (previous) (diff)

comment:4 Changed 9 years ago by Antoine gmail

You will get warnings until all the icons are found.
You can find a copy of them all here: browser/trunk/skel/share/winswitch/icons.
I'm not sure adding them will fix things, I don't have time to look into this right now.
It could be that the build scripts missed something, though they haven't really changed for a long time..

comment:5 Changed 9 years ago by Mc128k

Yep, that solves the issue. One of your scripts is not copying the winswitch folder (inside share) in the OSX app. After placing the icons now it works.

comment:6 Changed 9 years ago by Antoine gmail

Milestone: 0.12
Owner: set to Antoine gmail
Priority: criticalblocker
Status: newaccepted

Thanks, will rebuild the image ASAP.

comment:7 Changed 9 years ago by Antoine gmail

Owner: changed from Antoine gmail to student_meh
Status: acceptedassigned

Got it: the build got bigger and so some of the final bits like icons didn't fit in the DMG, r5329 fixes that by excluding things we don't really need.
I've briefly tested this on my dev box, but since I didn't see the problem before, it doesn't mean much.
Can you check that this updated DMG works for you?

comment:8 Changed 9 years ago by Mc128k

Yep, it works. Consider the ticket closed for me.

comment:9 Changed 9 years ago by Antoine gmail

Resolution: fixed
Status: assignedclosed

Thanks for testing!

Note: See TracTickets for help on using tickets.