Opened 4 years ago

Last modified 4 years ago

#279 new task

depends on deprecated python-rsvg

Reported by: onlyjob Owned by:
Priority: major Milestone: 1.1
Component: Global Keywords:
Cc:

Description

As reported in https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=790162 Winswitch depends on deprecated "python-rsvg":

winswitch should switch to using the GObject Introspection bindings for gnome-keyring, gir1.2-rsvg-2.0.


This would mean switching to GObject Introspection for other bindings as well, e.g. GLib and GTK+, so making the switch to GTK+ 3 at the same time would make a lot of sense.


For more information on GObject Introspection see [1] and [2].


[1] https://wiki.gnome.org/action/show/Projects/GObjectIntrospection
[2] https://wiki.gnome.org/action/show/Projects/PyGObject

Change History (1)

comment:1 Changed 4 years ago by Antoine gmail

Milestone: 1.1
Type: defecttask

Not going to happen anytime soon.

Moving to GTK3 is just too much pain.

Note: See TracTickets for help on using tickets.