Opened 3 years ago

Closed 3 years ago

#291 closed defect (fixed)

When attempting to start an application on Fedora 24 using WindowSwitch 0.12.21 you are informed that xpra is not supported.

Reported by: jayce1996 Owned by: jayce1996
Priority: major Milestone:
Component: Server Keywords:
Cc:

Description

If you try to start an application on a Fedora 24 server using WindowSwitch? 0.12.21, you get the following error dialog:

You have requested an xpra session but this server does not support it.

Attempting to start an xpra session directly using:
xpra start ssh:localhost:100 --start-child=xchat

actually produces an application.

xpra is installed in the same location that winswitch thinks it is.

Change History (5)

comment:1 Changed 3 years ago by Antoine Martin

Owner: set to jayce1996
Status: newassigned

@jayce1996: what xpra version are you using?

Please attach the winswitch log. Run it like so:

winswitch_applet --debug-mode > winswitch.log

comment:2 Changed 3 years ago by jayce1996

Do I need to do this on the server or client?
I'm using windows 10 as the client, if I need to do the debug at the client, how do I start that in debug mode?

comment:3 Changed 3 years ago by Antoine Martin

Please update to the latest version of xpra and winswitch.
The problems will probably just go away.
If not, please include the log from the side that is failing to recognise xpra as a supported protocol - in your case, the server?
(it wouldn't hurt to have both)

comment:4 Changed 3 years ago by jayce1996

Yes, this problem does seem to have been resolved by an update to the server software, many thanks.

comment:5 Changed 3 years ago by jayce1996

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.