Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#303 closed defect (invalid)

When the client connects to the server, there are port forwarding and application startup errors.

Reported by: Zueuk Owned by: Zueuk
Priority: major Milestone:
Component: Global Keywords:
Cc:

Description

When the client connects to the server, there are port forwarding and application startup errors.

[II] 2018/13/04 09:38:53.375532 ConchConnection.forward_port(12497,127.0.0.1,24065)
[II] 2018/13/04 09:39:31.742001 WinSwitchApplet.do_start_session(ServerConfig(desktop:158515233878749),Command(Mousepad: mousepad %F),xpra,None,{},False)
[II] 2018/13/04 09:39:31.742075 WinSwitchApplet.attention(Starting Mousepad,None)
[II] 2018/13/04 09:39:31.742134 StatusIconTray.animate_status_icon(Starting Mousepad,5) now=1523601571.74, tray_widget_animate_until=1523601505.56
[II] 2018/13/04 09:39:31.908503 ServerLink.add_port_forward(None,127.0.0.1,15071) adding new port forward
[II] 2018/13/04 09:39:31.908637 ConchConnection.forward_port(12498,127.0.0.1,15071)
[II] 2018/13/04 09:39:35.937471 ServerLineConnection.do_message(9e007000aad84b759b6f03735717ba4d,Session Mousepad Failed,Session failed to start,)
[II] 2018/13/04 09:39:54.238773 UI_Util.get_command_menu_entry(ServerConfig(desktop:158515233878749),Command(Gscriptor: gscriptor)) missing icon!
[II] 2018/13/04 09:39:54.239043 UI_Util.get_command_menu_entry(ServerConfig(desktop:158515233878749),Command(Jaxx: "/home/username/cryptowallets/jaxx-1.3.13-x86_64.AppImage" %U)) missing icon!
[II] 2018/13/04 09:39:54.240210 UI_Util.get_command_menu_entry(ServerConfig(desktop:158515233878749),Command(TurboVNC Viewer: /opt/TurboVNC/bin/vncviewer)) missing icon!
[II] 2018/13/04 09:39:54.241673 UI_Util.get_command_menu_entry(ServerConfig(desktop:158515233878749),Command(OpenCity: opencity)) missing icon!
[II] 2018/13/04 09:39:54.247141 UI_Util.get_command_menu_entry(ServerConfig(desktop:158515233878749),Command(aMule: amule %u)) missing icon!
[II] 2018/13/04 09:39:54.251555 UI_Util.get_command_menu_entry(ServerConfig(desktop:158515233878749),Command(Power Manager: xfce4-power-manager-settings)) missing icon!
[II] 2018/13/04 09:39:54.252573 UI_Util.get_command_menu_entry(ServerConfig(desktop:158515233878749),Command(TeXdoctk: texdoctk)) missing icon!
[II] 2018/13/04 09:39:54.253640 UI_Util.get_command_menu_entry(ServerConfig(desktop:158515233878749),Command(PyCrust: pycrust)) missing icon!
[II] 2018/13/04 09:39:54.255005 UI_Util.get_command_menu_entry(ServerConfig(desktop:158515233878749),Command(LMMS: env QT_X11_NO_NATIVE_MENUBAR=1 lmms %f)) missing icon!
[II] 2018/13/04 09:39:54.257128 UI_Util.get_command_menu_entry(ServerConfig(desktop:158515233878749),Command(GAdmin-Rsync: su-to-root -X -c /usr/sbin/gadmin-rsync)) missing icon!
[II] 2018/13/04 09:39:54.257361 UI_Util.get_command_menu_entry(ServerConfig(desktop:158515233878749),Command(GSmartControl: "/usr/bin/gsmartcontrol-root")) missing icon!
[II] 2018/13/04 09:39:54.259273 UI_Util.get_command_menu_entry(ServerConfig(desktop:158515233878749),Command(UNetbootin: /usr/bin/unetbootin)) missing icon!
[II] 2018/13/04 09:39:54.287996 WinSwitchApplet.do_start_session(ServerConfig(desktop:158515233878749),Desktop(Xfce Session: startxfce4),vnc,None,{},False)
[II] 2018/13/04 09:39:54.288073 WinSwitchApplet.attention(Starting Xfce Session,None)
[II] 2018/13/04 09:39:54.288128 StatusIconTray.animate_status_icon(Starting Xfce Session,5) now=1523601594.29, tray_widget_animate_until=1523601576.74
[II] 2018/13/04 09:39:54.547923 ServerLink.add_port_forward(None,127.0.0.1,16072) adding new port forward
[II] 2018/13/04 09:39:54.548147 ConchConnection.forward_port(12499,127.0.0.1,16072)
[II] 2018/13/04 09:39:55.599431 ProtocolHandler.do_encrypted_command(78296cadaa664db4903f9daf30f421f5e745774aa2ab268880acc074aa64e8b4be461c80a2b4e9d6cb5be604d2dc6d8d7...) decrypted command=send_session '4011ea7ccbbf4b4caa82f47d86bb0b98','9e007000aad84b759b6f03735717ba4d','base64:N2UyNGMwMmE= '
[II] 2018/13/04 09:39:55.599610 VNCClientUtil.attach(ServerConfig(desktop:158515233878749),ClientSession(:71 - vnc - connecting),127.0.0.1,12499)
[II] 2018/13/04 09:39:55.625427 VNCClientUtil.do_real_attach(ServerConfig(desktop:158515233878749),ClientSession(:71 - vnc - connecting),127.0.0.1,12499) saved password '#######' in /home/username/.winswitch/client/sessions/4011ea7ccbbf4b4caa82f47d86bb0b98/session.pass
[II] 2018/13/04 09:39:55.625532 VNCClientUtil.exec_client(ServerConfig(desktop:158515233878749),ClientSession(:71 - vnc - connecting),['/usr/bin/vncviewer', 'PasswordFile=/home/username/.winswitch/client/sessions/4011ea7ccbbf4b4caa82f47d86bb0b98/session.pass', 'name=Xfce Session on desktop', '127.0.0.1::12499'],None,None,available,True) starting SimpleLineProcess
[II] 2018/13/04 09:39:55.634440 VNCClientUtil.started(<winswitch.util.process_util.SimpleLineProcess instance at 0x7f5abbdf4dd0>) pid=None
[II] 2018/13/04 09:39:55.634966 SimpleLineProcess.start() process(['/usr/bin/vncviewer', 'PasswordFile=/home/username/.winswitch/client/sessions/4011ea7ccbbf4b4caa82f47d86bb0b98/session.pass', 'name=Xfce Session on desktop', '127.0.0.1::12499'])=<Process pid=6419 status=-1>
[II] 2018/13/04 09:39:56.214816 PortForwardChannel.__init__(<winswitch.net.conch_util.ConchConnection instance at 0x7f5ac06b5b48>,<function forwarding_ready at 0x7f5abbdd7578>,<function forwarding_failed at 0x7f5abbdd7aa0>)
[II] 2018/13/04 09:39:56.214968 ConchConnection.openChannel(<winswitch.net.conch_util.PortForwardChannel instance at 0x7f5abbdf4758>,'\x00\x00\x00\t127.0.0.1\x00\x00>\xc8\x00\x00\x00\t127.0.0.1\x00\x00\xcf\xde')
[II] 2018/13/04 09:39:56.215638 VNCClientUtil.handle_line_connected(ClientSession(:71 - vnc - connecting), CConn:       connected to host 127.0.0.1 port 12499) ServerConfig(desktop:158515233878749)
[II] 2018/13/04 09:39:56.215699 WinSwitchApplet.update_session_status(ServerConfig(desktop:158515233878749),ClientSession(:71 - vnc - connecting),connected)
[II] 2018/13/04 09:39:56.243185 ServerLink.forwarding_ready()

Attachments (3)

applet-20180410-131715.log (116.9 KB) - added by Zueuk 15 months ago.
server-20180427-082813.log.7z (24.2 KB) - added by Zueuk 15 months ago.
server-20180428.log.7z (7.3 KB) - added by Zueuk 15 months ago.

Download all attachments as: .zip

Change History (18)

Changed 15 months ago by Zueuk

Attachment: applet-20180410-131715.log added

comment:1 Changed 15 months ago by Antoine Martin

Owner: set to Zueuk
Status: newassigned

I don't see any port forwarding errors here, only:

ServerLineConnection.do_message(9e007000aad84b759b6f03735717ba4d,Session Mousepad Failed,Session failed to start,)

Have you tried with other applications?
To figure out why it is failing, you may need to run the remote winswitch server in debug mode.

comment:2 Changed 15 months ago by Zueuk

I tried. With all applications the same error. Here is the log file from the server (server-20180427-082813.log.7z).

Last edited 15 months ago by Zueuk (previous) (diff)

Changed 15 months ago by Zueuk

comment:3 Changed 15 months ago by Antoine Martin

Resolution: invalid
Status: assignedclosed

Closing as invalid.

As per your log sample, the problem is that your xpra package is incorrect / for the wrong distribution or release:

[DD] 2018/27/04 08:29:21.134790 XpraServerUtil.read_from_log(/home/username/.winswitch/server/sessions/62/xpra.log,20,ServerSession(:62 - xpra - starting)) read_pending=True
[II] 2018/27/04 08:29:21.134869 XpraServerUtil.process_log_line(ServerSession(:62 - xpra - starting),2018-04-27 08:29:21,033   ownership root:xpra\n)
[DD] 2018/27/04 08:29:21.134987 XpraServerUtil.process_log_data(ServerSession(:62 - xpra - starting),16 lines) new status(2018-04-27 08:29:21,033   ownership root:xpra\n)=None
[II] 2018/27/04 08:29:21.135039 XpraServerUtil.process_log_line(ServerSession(:62 - xpra - starting),xpra main error:\n)
[DD] 2018/27/04 08:29:21.135094 XpraServerUtil.process_log_data(ServerSession(:62 - xpra - starting),16 lines) new status(xpra main error:\n)=None
[II] 2018/27/04 08:29:21.135142 XpraServerUtil.process_log_line(ServerSession(:62 - xpra - starting),Traceback (most recent call last):\n)
[DD] 2018/27/04 08:29:21.135195 XpraServerUtil.process_log_data(ServerSession(:62 - xpra - starting),16 lines) new status(Traceback (most recent call last):\n)=None
[II] 2018/27/04 08:29:21.135243 XpraServerUtil.process_log_line(ServerSession(:62 - xpra - starting),  File "/usr/lib/python2.7/dist-packages/xpra/scripts/main.py", line 175, in main\n)
[DD] 2018/27/04 08:29:21.135297 XpraServerUtil.process_log_data(ServerSession(:62 - xpra - starting),16 lines) new status(  File "/usr/lib/python2.7/dist-packages/xpra/scripts/main.py", line 175, in main\n)=None
[II] 2018/27/04 08:29:21.135344 XpraServerUtil.process_log_line(ServerSession(:62 - xpra - starting),    return run_mode(script_file, err, options, args, mode, defaults)\n)
[DD] 2018/27/04 08:29:21.135397 XpraServerUtil.process_log_data(ServerSession(:62 - xpra - starting),16 lines) new status(    return run_mode(script_file, err, options, args, mode, defaults)\n)=None
[II] 2018/27/04 08:29:21.135444 XpraServerUtil.process_log_line(ServerSession(:62 - xpra - starting),  File "/usr/lib/python2.7/dist-packages/xpra/scripts/main.py", line 1517, in run_mode\n)
[DD] 2018/27/04 08:29:21.135497 XpraServerUtil.process_log_data(ServerSession(:62 - xpra - starting),16 lines) new status(  File "/usr/lib/python2.7/dist-packages/xpra/scripts/main.py", line 1517, in run_mode\n)=None
[II] 2018/27/04 08:29:21.135545 XpraServerUtil.process_log_line(ServerSession(:62 - xpra - starting),    return run_server(error_cb, options, mode, script_file, args, current_display)\n)
[DD] 2018/27/04 08:29:21.135598 XpraServerUtil.process_log_data(ServerSession(:62 - xpra - starting),16 lines) new status(    return run_server(error_cb, options, mode, script_file, args, current_display)\n)=None
[II] 2018/27/04 08:29:21.135645 XpraServerUtil.process_log_line(ServerSession(:62 - xpra - starting),  File "/usr/lib/python2.7/dist-packages/xpra/scripts/server.py", line 978, in run_server\n)
[DD] 2018/27/04 08:29:21.135698 XpraServerUtil.process_log_data(ServerSession(:62 - xpra - starting),16 lines) new status(  File "/usr/lib/python2.7/dist-packages/xpra/scripts/server.py", line 978, in run_server\n)=None
[II] 2018/27/04 08:29:21.135746 XpraServerUtil.process_log_line(ServerSession(:62 - xpra - starting),    from xpra.x11.gtk2.wm import wm_check\n)
[DD] 2018/27/04 08:29:21.135812 XpraServerUtil.process_log_data(ServerSession(:62 - xpra - starting),16 lines) new status(    from xpra.x11.gtk2.wm import wm_check\n)=None
[II] 2018/27/04 08:29:21.135861 XpraServerUtil.process_log_line(ServerSession(:62 - xpra - starting),  File "/usr/lib/python2.7/dist-packages/xpra/x11/gtk2/wm.py", line 28, in <module>\n)
[DD] 2018/27/04 08:29:21.135915 XpraServerUtil.process_log_data(ServerSession(:62 - xpra - starting),16 lines) new status(  File "/usr/lib/python2.7/dist-packages/xpra/x11/gtk2/wm.py", line 28, in <module>\n)=None
[II] 2018/27/04 08:29:21.135962 XpraServerUtil.process_log_line(ServerSession(:62 - xpra - starting),    from xpra.x11.bindings.keyboard_bindings import X11KeyboardBindings #@UnresolvedImport\n)
[DD] 2018/27/04 08:29:21.136015 XpraServerUtil.process_log_data(ServerSession(:62 - xpra - starting),16 lines) new status(    from xpra.x11.bindings.keyboard_bindings import X11KeyboardBindings #@UnresolvedImport\n)=None
[II] 2018/27/04 08:29:21.136073 XpraServerUtil.process_log_line(ServerSession(:62 - xpra - starting),ImportError: /usr/lib/python2.7/dist-packages/xpra/x11/bindings/keyboard_bindings.x86_64-linux-gnu.so: undefined symbol: PyFPE_jbuf\n)
[DD] 2018/27/04 08:29:21.136130 XpraServerUtil.process_log_data(ServerSession(:62 - xpra - starting),16 lines) new status(ImportError: /usr/lib/python2.7/dist-packages/xpra/x11/bindings/keyboard_bindings.x86_64-linux-gnu.so: undefined symbol: PyFPE_jbuf\n)=None

The key line is:

packages/xpra/x11/bindings/keyboard_bindings.x86_64-linux-gnu.so: undefined symbol: PyFPE_jbuf

comment:4 Changed 15 months ago by Zueuk

My Linux distro

#lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux testing (buster)
Release:        testing
Codename:       buster

And

/etc/apt/sources.list.d# cat winswitch.list 

deb http://winswitch.org/beta/ stretch main
deb http://winswitch.org/ stretch main

comment:5 Changed 15 months ago by Antoine Martin

There is a repository for buster, use it.
Don't use stretch as this will not work, buster is not ABI compatible with stretch.

Last edited 15 months ago by Antoine Martin (previous) (diff)

comment:6 Changed 15 months ago by Zueuk

Ok. I changed my winswitch.list.
Now

apt-cache policy xpra
xpra:
  Installed: 2.3-r19058-1
  Candidate: 2.3-r19058-1
  Version table:
 *** 2.3-r19058-1 500
        500 http://winswitch.org buster/main amd64 Packages
        100 /var/lib/dpkg/status
     2.3-r18985-1 500
        500 http://winswitch.org buster/main amd64 Packages
     2.3-20180423r19061-1 500
        500 http://winswitch.org/beta buster/main amd64 Packages
     2.3-20180421r19050-1 500
        500 http://winswitch.org/beta buster/main amd64 Packages
     2.3-20180410r19012-1 500
        500 http://winswitch.org/beta buster/main amd64 Packages
        500 http://winswitch.org buster/main amd64 Packages
     2.3-20180402r18940-1 500
        500 http://winswitch.org/beta buster/main amd64 Packages
     2.3-20180326r18853-1 500
        500 http://winswitch.org/beta buster/main amd64 Packages
     2.3-20180323r18810-1 500
        500 http://winswitch.org/beta buster/main amd64 Packages
     2.3-20180321r18788-1 500
        500 http://winswitch.org/beta buster/main amd64 Packages
     2.3-20180317r18744-1 500
        500 http://winswitch.org/beta buster/main amd64 Packages
     2.3-20180312r18707-1 500
        500 http://winswitch.org/beta buster/main amd64 Packages
     2.3-20180308r18669-1 500
        500 http://winswitch.org/beta buster/main amd64 Packages
     2.3-20180301r18657-1 500
        500 http://winswitch.org/beta buster/main amd64 Packages
     2.3-20180228r18646-1 500
        500 http://winswitch.org/beta buster/main amd64 Packages
     2.3-20180228r18641-1 500
        500 http://winswitch.org/beta buster/main amd64 Packages
     2.3-20180123r18126-1 500
        500 http://winswitch.org/beta buster/main amd64 Packages
     2.3-20180122r18115-1 500
        500 http://winswitch.org/beta buster/main amd64 Packages
     0.17.6+dfsg-1+b3 500
        500 http://mirror.yandex.ru/debian testing/main amd64 Packages

but

apt-cache policy winswitch
winswitch:
  Installed: 0.12.23-1
  Candidate: 0.12.23-1
  Version table:
 *** 0.12.23-1 100
        100 /var/lib/dpkg/status

What is wrong now?

comment:7 Changed 15 months ago by Antoine Martin

You need to completely remove the version you had installed then install again.

comment:8 Changed 15 months ago by Zueuk

All installed versions completely removed.

dpkg -l {xpra,winswitch}
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                      Version                   Architecture              Description
+++-=========================================-=========================-=========================-========================================================================================
un  xpra                                      <none>                    <none>                    (no description available)
dpkg-query: no packages found matching winswitch

and then

apt search xpra
Sorting... Done
Full Text Search... Done
xpra/buster 2.3-20180423r19061-1 amd64
  tool to detach/reattach running X programs

xpra-dbgsym/buster 2.3-20180423r19061-1 amd64
  debug symbols for xpra

and

apt search winswitch
Sorting... Done
Full Text Search... Done

Maybe something is wrong with the repository?

comment:9 Changed 15 months ago by Antoine Martin

winswitch has not been built for buster yet.
You can:

  • build from source: setup.py install
  • use the stretch builds (winswitch is pure python)

Changed 15 months ago by Zueuk

Attachment: server-20180428.log.7z added

comment:10 Changed 15 months ago by Zueuk

Ok. Now I have installed the same versions on the client and on the server.
But application not running.
server-20180428.log.7z

Last edited 15 months ago by Antoine Martin (previous) (diff)

comment:11 Changed 15 months ago by Antoine Martin

For some unknown reason, your session never reaches the ready state:

[DD] 2018/28/04 08:33:50.158215 XpraServerUtil.do_read_from_log(/home/username/.winswitch/server/sessions/64/xpra.log,24,ServerSession(:64 - xpra - starting)) read 0 bytes
[II] 2018/28/04 08:34:12.737557 WinSwitchServer.session_failed(ServerSession(:64 - xpra - starting),Session failed to start, waited 30 seconds,closed)

Try running xpra by hand and post the output:

xpra --bind-tcp=0.0.0.0:10000 --no-daemon --systemd-run=no \
    --session-name=Mousepad start :10
Last edited 15 months ago by Antoine Martin (previous) (diff)

comment:12 Changed 15 months ago by Zueuk

Output:

[email protected]:~$ xpra --bind-tcp=0.0.0.0:10000 --no-daemon --systemd-run=no --session-name=Mousepad start :10 &
[1] 18708
[email protected]:~$ 2018-04-28 09:32:42,404 cannot access python uinput module:
2018-04-28 09:32:42,404  No module named uinput

X.Org X Server 1.19.6
Release Date: 2017-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.9.0-5-amd64 x86_64 Debian
Current Operating System: Linux desktop 4.15.0-2-amd64 #1 SMP Debian 4.15.11-1 (2018-03-20) x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-2-amd64 root=/dev/mapper/vg_desktop-lv_root ro intel_iommu=on quiet
Build Date: 26 January 2018  04:30:21PM
xorg-server 2:1.19.6-1 (https://www.debian.org/support) 
Current version of pixman: 0.34.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/run/user/1000/xpra/Xorg.:10.log", Time: Sat Apr 28 09:32:42 2018
(++) Using config file: "/etc/xpra/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
2018-04-28 09:32:44,931 Warning: some of the sockets are in an unknown state:
2018-04-28 09:32:44,931  /run/user/1000/xpra/desktop-10
2018-04-28 09:32:44,931  /home/peter/.xpra/desktop-10
2018-04-28 09:32:44,932  please wait as we allow the socket probing to timeout
2018-04-28 09:32:50,956 created unix domain socket: /run/user/1000/xpra/desktop-10
2018-04-28 09:32:50,957 created unix domain socket: /home/peter/.xpra/desktop-10
2018-04-28 09:32:50,957 Warning: cannot create socket '/run/xpra/desktop-10'
2018-04-28 09:32:50,957  [Errno 13] Отказано в доступе
2018-04-28 09:32:50,958  user 'username' is a member of groups: cdrom, floppy, audio, dip, video, plugdev, netdev, lpadmin, scanner, bluetooth, davfs2, vboxusers, kvm, libvirt, libvirt-qemu
2018-04-28 09:32:50,958   missing 'xpra' group membership?
2018-04-28 09:32:50,958   permissions on directory /run/xpra: 0775
2018-04-28 09:32:50,958   ownership root:xpra
2018-04-28 09:32:51,026 pointer device emulation using XTest
2018-04-28 09:32:52,125 serving html content from: /usr/share/xpra/www
2018-04-28 09:32:52,292 D-Bus notification forwarding is available
2018-04-28 09:32:52,621 Warning: webcam forwarding is disabled
2018-04-28 09:32:52,621  the virtual video directory '/sys/devices/virtual/video4linux' was not found
2018-04-28 09:32:52,621  make sure that the 'v4l2loopback' kernel module is installed and loaded
2018-04-28 09:32:52,621 found 0 virtual video devices for webcam forwarding
2018-04-28 09:32:52,632 pulseaudio server started with pid 18809
2018-04-28 09:32:52,633  private server socket path:
2018-04-28 09:32:52,633  '/run/user/1000/xpra/pulse-:10/pulse/native'
W: [pulseaudio] pid.c: Stale PID file, overwriting.
2018-04-28 09:32:53,691 GStreamer version 1.14.0 for Python 2.7.15 64-bit
2018-04-28 09:32:53,765 xpra X11 version 2.3-r19058 64-bit
2018-04-28 09:32:53,765  uid=1000 (peter), gid=1000 (peter)
2018-04-28 09:32:53,765  running with pid 18708 on Linux Debian testing buster
2018-04-28 09:32:53,765  connected to X11 display :10 with 24 bit colors
2018-04-28 09:32:53,835 xpra is ready.
2018-04-28 09:32:57,067 printer forwarding enabled using postscript and pdf
2018-04-28 09:32:57,069 15.2GB of system memory

comment:13 Changed 15 months ago by Zueuk

2018-04-28 09:32:50,957  [Errno 13] Отказано в доступе

means

2018-04-28 09:32:50,957  [Errno 13] Access denied

comment:14 Changed 15 months ago by Antoine Martin

That worked fine, winswitch is waiting for this line of output:

xpra is ready.

And for whatever reason, it doesn't see it when it executes xpra.
No idea why, sorry.

comment:15 Changed 15 months ago by Zueuk

It is sad. Thank you for help!

Note: See TracTickets for help on using tickets.