Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#283 closed defect (invalid)

Windows plink binary needs updating

Reported by: Nathan Rennie-Waldock Owned by: Nathan Rennie-Waldock
Priority: major Milestone:
Component: Windows Build Keywords:
Cc:

Description

The Windows plink binary needs updating as it has very limited MAC algorithm support and newer Linux distros have disabled those by default.

Log connecting to an Ubuntu 15.04 server: sshd[27346]: fatal: no matching mac found: client hmac-sha1,hmac-md5 server [email protected]…,[email protected]…,[email protected]…,hmac-sha2-512,hmac-sha2-256,hmac-ripemd160 [preauth]

Change History (3)

comment:1 Changed 4 years ago by Antoine Martin

Owner: set to Nathan Rennie-Waldock
Status: newassigned

Is this plink or twisted conch?
We use conch for connecting from winswitch, plink is only used with xpra.

We use the plink version from tortoise svn rather than putty's, as the tortoise version has GUI support for key and host verification, etc..

I've tried to update tortoisesvn to get a newer version of tortoiseplink, but the 32-bit version no longer supports XP and the 64-bit version contains a 64-bit build of plink... which doesn't run on 32-bit.

Can you try to if you can install the 32-bit version somewhere?
Then you should be able to copy tortoiseplink.exe over xpra's plink.exe and it should work.
If it does solve the problems, then I'll find a way of extracting it and update the build environment with it.

comment:2 Changed 4 years ago by Nathan Rennie-Waldock

Resolution: invalid
Status: assignedclosed

Alright, seems I forgot to remove sha1 from my sshd config. So tortoiseplink does support it, but twisted doesn't. I'll have to just leave sha1 enabled then.

comment:3 Changed 4 years ago by Antoine gmail

Dupe of #270.

Note: See TracTickets for help on using tickets.