Opened 4 years ago

Closed 4 years ago

#284 closed defect (fixed)

[PATCH] Fix incorrect icons for some apps

Reported by: Nathan Rennie-Waldock Owned by:
Priority: minor Milestone:
Component: Server Keywords:
Cc:

Description

Some apps are showing the incorrect icon in the applications menu.
After a lot of debugging, I figured out icons with an extension will always be replaced by an icon found after it.

In my case, Thunderbird was getting the icon from my icon theme, rather than the package one which was found first.

It was caused by checking for the filename *with* extension as the key, rather than without which is how they're stored.

Attachments (1)

Fix icon search.patch (732 bytes) - added by Nathan Rennie-Waldock 4 years ago.

Download all attachments as: .zip

Change History (2)

Changed 4 years ago by Nathan Rennie-Waldock

Attachment: Fix icon search.patch added

comment:1 Changed 4 years ago by Antoine gmail

Resolution: fixed
Status: newclosed

Applied in r5333.

Thanks!

Note: See TracTickets for help on using tickets.