Opened 3 years ago

Closed 3 years ago

#285 closed defect (fixed)

connecting with ssh to winswitch server is failing.

Reported by: Kundan Kumar Owned by: Kundan Kumar
Priority: major Milestone:
Component: Client Keywords:
Cc:

Description

While winswitch client is trying to connect to some other winswitch server through m_DNS. It is failing to connect through ssh. Through Direct connection it succeeds. But, opening a remote application, doesn't shows on the requesting host.

I am running latest winswitch version 0.12.21, with xpra version 0.16.1. My both host system where connection is expected, is Ubuntu 15.04. I have also seen this issue in Ubuntu 15.10.

I tried to run the winswitch_applet in debug mode. Attaching a screenshot for the same.

Attachments (3)

Screenshot from 2016-02-04 21:01:45.png (450.4 KB) - added by Kundan Kumar 3 years ago.
Screenshot when the SSH failed.
sshd_log (1.2 KB) - added by Kundan Kumar 3 years ago.
sshd log.
sshd_log_accepted (1.4 KB) - added by Kundan Kumar 3 years ago.
sshd log when connection was accepted through a separate connection, without winswitch.

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by Kundan Kumar

Screenshot when the SSH failed.

comment:1 Changed 3 years ago by Antoine gmail

Owner: set to Kundan Kumar
Status: newassigned

The cause of the ssh failure is probably available in your syslog / sshd log.
All we see from this end is connection was closed cleanly.

PS: screenshots are great, but for text data, please use attachments.

Changed 3 years ago by Kundan Kumar

Attachment: sshd_log added

sshd log.

Changed 3 years ago by Kundan Kumar

Attachment: sshd_log_accepted added

sshd log when connection was accepted through a separate connection, without winswitch.

comment:2 Changed 3 years ago by Kundan Kumar

Owner: changed from Kundan Kumar to Antoine gmail

It seems that the ssh connection failure is due to, the following line in sshd_log.

fatal: Unable to negotiate a key exchange method [preauth]

When, ssh connection is initiated without winswitch, connection is accepted by the server, and following message comes.

Accepted password for abhishek from 192.168.56.103 port 51379 ssh2
pam_unix(sshd:session): session opened for user abhishek by (uid=0)

comment:3 Changed 3 years ago by Antoine gmail

Owner: changed from Antoine gmail to Kundan Kumar

I believe that the issue you are having is the same as #270: your version of twisted conch does not support the newer key exchange algorithms and so the ssh connection fails.
I very much doubt Debian / Ubuntu will fix this incompatibility by patching or upgrading Twisted, so your only option is to add the deprecated key exchange options as per ticket:270#comment:7.

Please close if this works for you.

comment:4 Changed 3 years ago by Kundan Kumar

Resolution: fixed
Status: assignedclosed

Yes, it worked for me.

Note: See TracTickets for help on using tickets.