Opened 8 years ago

Closed 8 years ago

#150 closed defect (invalid)

Keyboard focus problem, OSX, xpra

Reported by: tlc Owned by: Antoine Martin
Priority: major Milestone: 0.12
Component: Xpra Keywords: OSX, xpra, keyboard focus
Cc:

Description

When using xpra with an OSX client and an Ubuntu server, I have consistent keyboard focus problems.

Whenever the app opens a secondary window, clicking fields, or anywhere on the secondary window will not give keyboard focus to a field.

I can work around by clicking the titlebar of the original app window, then moving back to the secondary window. Then my mouse clicks will affect keyboard focus.

Change History (9)

comment:1 Changed 8 years ago by Antoine Martin

Owner: changed from Antoine Martin to Antoine Martin
Status: newaccepted

This sounds like the same problem that led to the removl of the gtk.StatusIcon (aka tray) on osx, if so then this is a gtk bug which can only be solved by gtk devs. I'll try to find the link to the upstream bug and paste it here.

comment:2 in reply to:  1 Changed 8 years ago by tlc

I don't know the internals, but I'll note that with this issue, MOUSE focus does work -- any buttons on the secondary window work and I can even highlight text in the fields. I just can't enter text.

The gtk tray icon issue I believe you're referring to, https://bugzilla.gnome.org/show_bug.cgi?id=549153 , appears to be about mouse focus and making an application active.

Is #77 the local ticket for OSX tray icon issues? I wanted to add some notes about that as well.

comment:3 Changed 8 years ago by Antoine Martin

Milestone: 0.12

comment:4 Changed 8 years ago by rainwoodman

I see the exact same problem on Windows 7.

comment:5 Changed 8 years ago by tlc

I've realized that it's only some applications. I have the problem with xchat, abiword, pidgen, transmission, vlc, HandBrake and calibre. But there's one app I don't see it on, kmttg (a Custom Command).

Last edited 8 years ago by Antoine Martin (previous) (diff)

comment:6 Changed 8 years ago by rainwoodman

Looks like when a new window (of some special wm hints) pops up, it is raised but not automatically focused. When you then switch away from on the client machine to a non-winswitch window and switch back, the application window is then properly focused.

I remember GTK has a similar gdk_window_set_focus that can implements the underlining X messages.

comment:7 Changed 8 years ago by Antoine Martin

Sorry about the delay, I will take a look at this asap.
Does this occur on all client platforms or just on OSX/win32? (I don't think I have seen the problem with Linux clients before)

comment:8 Changed 8 years ago by Antoine Martin

Also confirmed on Linux, I have seen it happen when the ssh-agent pops up (it gets focus) and then disappears (window should get the focus back but does not).

comment:9 Changed 8 years ago by Antoine Martin

Resolution: invalid
Status: acceptedclosed

Moved to xpra's bug tracker: #51 as this is an xpra bug not winswitch. Will try to fix asap.

Note: See TracTickets for help on using tickets.